ATS MapsATS Mods

ATS – Interstate 10 (1.35.x)

ATS v1.35 COMPATIBLE!
CanaDream 2.8.15 COMPATIBLE!
Coast to Coast Map – v2.8.3 COMPATIBLE!

Changes 1.35
Mod update for 1.35

Requirements:
Coast to Coast Map – v2.8.3
Supported game versions: ATS – (1.35.x)

Authors: Rickpp, update Mantrid

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close