ATS MapsATS Mods

Canadream V2.40 ATS 1.40

Version 2.40 Changelog:
Update for 1.40

Coast to Coast map 2.11.12 minimum is REQUIRED for playing or game crash

Priority:
1-CanaDream 2.40
2-Coast to Coast Map v2.11.12

compatible ATS 1.40
compatible C2C 2.11.12

Supported game versions: ATS – (1.40.x)

Authors: ManiaX, update Mantrid

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close