Daf Euro 6 Low Chassis V4.0 ETS2 (1.43.x)

Euro Truck Simulator 2 Daf Euro 6 Low Chassis V4.0 mod download.

Updates:
Fixed the issue of hovering in the store.
The error that occurred on the game loading screen has been fixed.
Tested at 1.43
Suitable for any version.

Supported game versions: ETS2 – 1.43.x

Authors: Ataberk

You may also like...

Leave a Reply

Your email address will not be published.