ETS2 – Alexd Double Earnings V1.3 (1.35.x)

This mod requires ETS2 1.31;1.32; 1.33.x 1.34.x 1.35.x
Updated to version 1.35.x
Double Earnings for Jobs(if you like to make money easier)

Supported game versions: ETS2 – (1.35.x)

Authors: ALEXD

You may also like...

Leave a Reply

Your email address will not be published.