ETS 2 ModsETS2 Skin

ETS2 – Dsv Krone Cooliner (1.36.x)

DSV for Krone Cooliner
DLC required.
Supported game versions: ETS2 – (1.36.x)

Authors: SCS
Johnodee
Modstudio 2

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close