ETS 2 ModsETS2 Other Mods

ETS2 – Film Simulation Reshade (1.35.x)

Requirements:
ReShade 4.4 (4.3), LUT.fx
Supported game versions: ETS2 – (1.35.x)

Authors: Nihonsakari

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close