ETS 2 ModsETS2 Other Mods

ETS2 – Fix Sky (1.38.x)

With this file you will be able to correct the sky error and thus use your old graphics mods in version 1.38 of ETS2.
Supported game versions: ETS2 – (1.38.x)

Authors: AREATZA(Tigre Blanco)

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close