ETS2 – Fixed Rusmap V1.8.1 For Baltic Dlc (1.33.x)

– RusMap v1.8.1 fixed to run on patch 1.33 + DLC Baltic
– Replace existing files with files from the archive.

* Fix for 1.32 can be removed.
Supported game versions: ETS2 – (1.33.x)

Authors: Sibir

You may also like...

Leave a Reply

Your email address will not be published.