ETS 2 ModsETS2 Maps

ETS2 – Old German Border Mod Great Steppe Fix (1.39.x)

FIX for the Old Inner German Border Mod V1.1 for THE GREAT STEPPE
Works with game version 1.39.x
Supported game versions: ETS2 – (1.39.x)

Authors: MapMaker

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close