Home ETS 2 Mods ETS2 – Remoled Next Gen V1.8.2 (1.35.x)

ETS2 – Remoled Next Gen V1.8.2 (1.35.x)

59
0

Fixed mirrors error
Sort of fixed eyebrows (it works lol) – Gives incorrect pmd version (yellow error in log)
V1.8 Added
1.35 compatibility.

Supported game versions: ETS2 – (1.35.x)

Author(s): Solutech

ETS2 – Remoled Next Gen V1.8.2 (1.35.x) Download File

LEAVE A REPLY

Please enter your comment!
Please enter your name here