ETS 2 ModsETS2 Skin

ETS2 – Visbeen for Krone Cool Liner (1.38.x)

DLC required
Tested on 1.38 version
Supported game versions: ETS2 – (1.38.x)

Authors: SCS
Modstudio 2
johnodee

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close