ETS 2 ModsETS2 Other Mods

Low & High Beam Flare Effect ETS2 1.39

You can see the different on video
before, this mod work on 1.30 version. Now im tested it on 1.39 and look it work properly.
Base model & textures flare by Abbastrepass

Supported game versions: ETS2 – (1.39.x)

Authors: Gilang Wisnu,Abbastrepass,BWS

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close