Ng Lowering ETS2 (1.44)

Euro Truck Simulator 2 NG Lowering mod download.

Next gen lowering mod

works on all NG tandems
works on 1.40 and up!

Supported game versions: ETS2 – 1.44

Authors: Rasken

You may also like...

Leave a Reply

Your email address will not be published.