ETS 2 ModsETS2 Other Mods

Real Traffic Density ETS2 1.40

Real Traffic Density compatibility update for 1.40 beta

warning! use with caution, any game update may break the mod and I will not notice this since I no longer update my SCS games for personal reasons (updates for my mods are possible thanks to trustful people sending to me the game files after updates.

Supported game versions: ETS2 – (1.40.x)

Authors: Cip

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close