ETS 2 ModsETS2 Interior Mods

Volvo Eugene Interior ETS2 1.39

It have definitely some small errors but nothing wrong that you cant play with it.
WORKS ONLY ON 1.39.x!
Supported game versions: ETS2 – (1.39.x)

Authors: TheBatmanLP

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close