ATS – Canadream V2.8.7 (1.34.x)

Like Comment

Changelog 2.8.7
Released as 2.8.7. It fixes the time zone issues

Coast to Coast map 2.7 minimum is REQUIRED for playing or game crash

Priority:
1-CanaDream 2.8.6
2-Coast to Coast 2.7

v2.8.7
compatible ATS 1.34
compatible C2C 2.7
add .sui system files for more compatibility with other mods

Supported game versions: ATS – (1.34.x)

You might like

About the Author: TruckSimulator

Best Truck Simulator Game Mods. Euro Truck Simulator 2 and American Truck Simulator mods.

Leave a Reply

Your email address will not be published. Required fields are marked *