ATS ModsATS Other Mods

ATS – Double Earnings V1.2 (1.35.x)

This mod requires ATS 1.31; 1.32; 1.33.x ; 1.34.x ; 1.35.x

V1.2 Update to 1.35.x
V1.1 New Version !

Double Earnings for Jobs(if you like to make money easier)
Supported game versions: ATS – (1.35.x)

Authors: ALEXD

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close