Canadream Map V2.41 ATS 1.41

Changelog 2.41
updated to ATS v1.41.

Coast to Coast map 2.11.15 minimum is REQUIRED for playing or game crash

Priority:
1-CanaDream 2.41
2-Coast to Coast 2.11.15

compatible ATS 1.41
compatible C2C 2.41
Supported game versions: ATS – (1.41.x)

Authors: ManiaX, update Mantrid

You may also like...

Leave a Reply

Your email address will not be published.