ATS MapsATS Mods

Canadream V2.40.1 ATS 1.40

Changelog v2.40.1
Canadream updated to exclude Montana Expansion

Coast to Coast map 2.11.14 minimum is REQUIRED for playing or game crash

Priority:
1-CanaDream 2.40.1
2-Coast to Coast Map v2.11.14

compatible ATS 1.40
compatible C2C 2.11.14

Supported game versions: ATS – (1.40.x)

Authors: ManiaX, update Mantrid

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close