ETS 2 ModsETS2 Skin

Elytrans-Line Skin V1.0 ETS2 1.40

For Scania RJL
Use Topline Cab only
Supported game versions: ETS2 – (1.40.x)

Authors: inhar3

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close