ETS 2 – Advanced Flash Lights for All Trucks (1.30.X)

Advanced Flash Lights for All Trucks Mod.

– Compatibility adjustment for 1.28 and 1.30 and all others.

Supported game versions: ETS 2 – 1.30.X

Authors: mikojub

You may also like...

Leave a Reply

Your email address will not be published.