ETS2 – Beacon Package V1.4 (1.35.x)

Like Comment

New Version 1.4:
– updated for compatibility with ETS2 v1.35.x
* New version will not work with game version 1.34 or less.

This pack contains modified versions of 50keda’s beacon.
Also compatible with small beacon slots on MADster’s MANs.
Many thanks to 50keda for use of the original model.

Supported game versions: ETS2 – (1.35.x)

You might like

About the Author: TruckSimulator

Best Truck Simulator Game Mods. Euro Truck Simulator 2 and American Truck Simulator mods.

Leave a Reply

Your email address will not be published. Required fields are marked *