ETS 2 ModsETS2 Trailer Mods

ETS2 – Trailer Pack (1.38.x)

After that you need to activate the mods you want to use.
1.37 — 1.38
Supported game versions: ETS2 – (1.38.x)

Authors: Stanley

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close