ETS 2 ModsETS2 Other Mods

Simple Colored Map ETS2 1.40

Colored Map
Supported for ETS2 latest version.

Compatible Map(s)
Default Map (+All Official DLC’s)
Supported game versions: ETS2 – (1.40.x)

Authors: PigeonBB

Leave a Reply

Your email address will not be published. Required fields are marked *

Back to top button
Close