ETS2 – Addon Petersburg And Vyborg For Rusmap V2.1.1 (1.37.x)

Addon Petersburg and Vyborg for RusMap 2.1.1
For those who want to use the extended version of St. Petersburg and Vyborg from Rusmap 1.9.2 together with Rusmap 2.1.1
Requires “RusMap” v2.1.1 or later.
Test on version 1.37
Copy to the mod folder and connect the RusMap files in the manager above.

Supported game versions: ETS2 – (1.37.x)

Authors: Sergey061, Schura774

You may also like...

Leave a Reply

Your email address will not be published.